Missing menus from TFT display - Abarth 500

General messages
snowbound_sonic
Posts: 25
Joined: 15 Mar 2017, 12:32

Missing menus from TFT display - Abarth 500

Postby snowbound_sonic » 22 Mar 2017, 22:42

Hi all,

I have a UK 2011 Abarth 500 to which I've fitted a TFT speedo.

The problem I have is that most of the menu options that should exist, are missing. The TFT speedo has the following:
Service
Passenger airbag
Dimmer
Speed beep
Trip B data
Buzzer volume

The original speedo had:
MENU
DIMMER
SPEED BEEP
TRIP B DATA/TRIP B DATA ACTIVATION
SET TIME
SET DATE
SEE RADIO
AUTOCLOSE
UNIT
LANGUAGE
BUZZER VOLUME
BUTTON VOL.
SEAT BELT BUZZER/SEAT BELT BEEPING *
SERVICE
PASSENGER BAG
DAYLIGHTS
EXIT MENU

I've looked at a TFT speedo in a new 500 (factory fitted) and it matches closely with my original one.

Now, I've plugged MES into the car and have the following errors:

Body
Body Computer Delphi (312)
ISO Code: 40 83 D6 89 F7
Errors found:
U1705 - Receiver Radio (NRR)
B1033 - Daylights
B1022 - Left or front side lights

Dashboard
Instrument Panel Marelli TFT
ISO Code: 00 03 40 25 14
Errors found:
U1700 - No Body Computer

Dashboard
Convergence Lauberhorn (Blue&Me)
ISO Code: B5 83 10 89 26
Errors found:
U1705 - Radio Receiver


I presume that because I have a Kenwood stereo, the system reports the radio missing (U1705). Am I right in thinking that the system needs to be told that there is no radio and that will restore some menu options such as adjusting the date/time? Or would that be to do with the U1700 that the speedo can't communicate with the BCM for whatever reason?

Any help or guidance would be gratefully appreciated - thank you in advance.
nufan0000
Posts: 33
Joined: 19 Jan 2017, 06:32

Re: Missing menus from TFT display - Abarth 500

Postby nufan0000 » 14 Apr 2017, 22:31

I have the same issue too when I move to the TFT and still have not figure out how to fix this. I got a china headunit too and I did every single combination and still can not get it working. did you try using the latest multiecuscan? Did it do anything? Cause on his note he stated that the proxi alignment added more support. Let me know if it works or not. I kinda gave up on it and I tried to get a custom alignment proxi setup so I can modified it but no one can help me out.
snowbound_sonic
Posts: 25
Joined: 15 Mar 2017, 12:32

Re: Missing menus from TFT display - Abarth 500

Postby snowbound_sonic » 16 Apr 2017, 21:38

I've since tried the following, to no avail...

TFT with...
Original radio = Time flashes; unable to change date/time (menu does not exist); other menu features not available (as per original post)
Aftermarket radio = Time flashes; unable to change date/time (menu does not exist); other menu features not available (as per original post)

New TFT with zero km (don't ask!) = As above. This leads me to believe that the cluster is unlikely to be faulty.

Analogue cluster with...
Original radio = All good - all menu features available
Aftermarket radio = All good - all menu features available

What I thought of doing, if the original radio needed to be connected, is to hide it out of the way in the boot and run whatever wires as an extension, tapping into the original loom back into the car but from what I can gather, the original radio has standard ISO A/B/C. Also, I would have thought if it had anything to do with the radio, it would have worked when I plugged the original back in with the TFT.

I changed the graphics to the Abarth by changing byte 65 to the value 60 and did a proxy-alignment.

This guy (http://www.fiatforum.com/500/434392-retrofit-lcd-instrument-cluster.html) is running a 2015 cluster in a 2008 car and he's not reported any issues - the date on the speedo matched the post's date!

I've been speaking with the guy who sold me the TFT and it worked fine in his car (retro-fitted).

It seems like the TFT has defaulted to a template that contains different menu features for different markets. Just need to activate the template somehow! It still doesn't explain why the most basic feature of setting the time and date isn't available though.

I've just downloaded version 3.6. I'll plug in it and see if there's anything else I can play with over the next few days and will post it on here.
nufan0000
Posts: 33
Joined: 19 Jan 2017, 06:32

Re: Missing menus from TFT display - Abarth 500

Postby nufan0000 » 18 Apr 2017, 17:38

Let me know, I have done everything you did!!! I am trying to get BLUE AND ME Back too and it doesn't work! My bluetooth stock unit works with no issue but right now but it does not give me any feedback on the screen. So Let me know if you find any update! I think it is the coding in the proxy alignment or custom proxy alignment to get the adjustment right cause I believe the TFT was intro in 2015 and my car is a 2015, so the coding might not be correct for the proxi alignment for the 2015. I feel that the dealership knows how to get it back but I am not too sure if they will even bother touching it. But let me know if you find anything or how to get it back? I was trying to ask Yami to look into this but it looks like the forum have no help from this.
alex-et3
Posts: 123
Joined: 19 Apr 2017, 22:42
Location: ROVIGO - Italy

Re: Missing menus from TFT display - Abarth 500

Postby alex-et3 » 19 Apr 2017, 22:46

I have mounted a lot of odometer TFT.
The problem is that they are not all the same.
You find yourself with the short menu because you have mounted that of 500 restyling.
It has the Uconnect radio(touch) and the date and time and other settings are set there.
You can not do anything to solve the problem because it is the software that changes between the TFT for 500 prerestyling and 500 restyling .
nufan0000
Posts: 33
Joined: 19 Jan 2017, 06:32

Re: Missing menus from TFT display - Abarth 500

Postby nufan0000 » 19 Apr 2017, 23:12

alex-et3 wrote:I have mounted a lot of odometer TFT.
The problem is that they are not all the same.
You find yourself with the short menu because you have mounted that of 500 restyling.
It has the Uconnect radio(touch) and the date and time and other settings are set there.
You can not do anything to solve the problem because it is the software that changes between the TFT for 500 prerestyling and 500 restyling .



The issue is that the car that I pull my off is from a 2015 that doesn't have uconnect and same as the other guy. They were working with older cars but after we proxi alignment the menu just went missing. So I am thinking that it got to be with the iso for the 2015 that are different then 2012. Consider that the part number are all the same. I remember yani said that as long as you proxi alignment again with the stock radio it should show up, but the issue is that that coding might not exist or something in the custom proxi alignment needs to be adjust to reprogram it. So right now we are waiting for someone to help. I don't know if anyone can pull it. Cause in the state, they did sell the TFT in 2015 with the blue and me and also same in the UK where uconnect wasn't introduce until 2016.
nufan0000
Posts: 33
Joined: 19 Jan 2017, 06:32

Re: Missing menus from TFT display - Abarth 500

Postby nufan0000 » 19 Apr 2017, 23:15

Like we stated this happen when we did a custom proxi and then the menu disappear. My clock wasn't flashing until I did a custom alignment to adjust the cluster to sport


I've been speaking with the guy who sold me the TFT and it worked fine in his car (retro-fitted).


As thhe other guy said the same thing, everything was working until custom alignment. So can anyone help to look into the custom alignment, maybe there is a code that shut off that is uconnect or something. not too sure
alex-et3
Posts: 123
Joined: 19 Apr 2017, 22:42
Location: ROVIGO - Italy

Re: Missing menus from TFT display - Abarth 500

Postby alex-et3 » 20 Apr 2017, 07:47

nufan0000 wrote:
alex-et3 wrote:I have mounted a lot of odometer TFT.
The problem is that they are not all the same.
You find yourself with the short menu because you have mounted that of 500 restyling.
It has the Uconnect radio(touch) and the date and time and other settings are set there.
You can not do anything to solve the problem because it is the software that changes between the TFT for 500 prerestyling and 500 restyling .



The issue is that the car that I pull my off is from a 2015 that doesn't have uconnect and same as the other guy. They were working with older cars but after we proxi alignment the menu just went missing. So I am thinking that it got to be with the iso for the 2015 that are different then 2012. Consider that the part number are all the same. I remember yani said that as long as you proxi alignment again with the stock radio it should show up, but the issue is that that coding might not exist or something in the custom proxi alignment needs to be adjust to reprogram it. So right now we are waiting for someone to help. I don't know if anyone can pull it. Cause in the state, they did sell the TFT in 2015 with the blue and me and also same in the UK where uconnect wasn't introduce until 2016.

No, the 500 restylings were introduced in 2015.
If you give me the fiat code of your tft I can check for which model is suitable.
I work in a fiat workshop and I have access to the spare parts program.
I sold and installed about 50 tft, so I know the differences.
Does the 500 depicted in your odometer have the new type backlights?
nufan0000
Posts: 33
Joined: 19 Jan 2017, 06:32

Re: Missing menus from TFT display - Abarth 500

Postby nufan0000 » 20 Apr 2017, 17:57

alex-et3 wrote:
nufan0000 wrote:
alex-et3 wrote:I have mounted a lot of odometer TFT.
The problem is that they are not all the same.
You find yourself with the short menu because you have mounted that of 500 restyling.
It has the Uconnect radio(touch) and the date and time and other settings are set there.
You can not do anything to solve the problem because it is the software that changes between the TFT for 500 prerestyling and 500 restyling .



The issue is that the car that I pull my off is from a 2015 that doesn't have uconnect and same as the other guy. They were working with older cars but after we proxi alignment the menu just went missing. So I am thinking that it got to be with the iso for the 2015 that are different then 2012. Consider that the part number are all the same. I remember yani said that as long as you proxi alignment again with the stock radio it should show up, but the issue is that that coding might not exist or something in the custom proxi alignment needs to be adjust to reprogram it. So right now we are waiting for someone to help. I don't know if anyone can pull it. Cause in the state, they did sell the TFT in 2015 with the blue and me and also same in the UK where uconnect wasn't introduce until 2016.

No, the 500 restylings were introduced in 2015.
If you give me the fiat code of your tft I can check for which model is suitable.
I work in a fiat workshop and I have access to the spare parts program.
I sold and installed about 50 tft, so I know the differences.
Does the 500 depicted in your odometer have the new type backlights?



I would need to pull it out again. The USA did not get the restyling that's why. The US Fiat 500 were selling the TFT with the old radio blue and me until 2015. 2016 for the US was when they change everything to TFT with the uconnect. So the market is very different. Only the UK receive it. The US were stuck with the same old Fiat 500 and same as the Blue and Me system that never gets updated. Can you show me what the new type of backlight, so I can compare it? But the time and date show on the TFT until I did a custom proxi alignment then it is gone. Do you have the part number that will work in my car ?
alex-et3
Posts: 123
Joined: 19 Apr 2017, 22:42
Location: ROVIGO - Italy

Re: Missing menus from TFT display - Abarth 500

Postby alex-et3 » 20 Apr 2017, 19:31

To give you a certain answer I absolutely have to know the code of your TFT.
With regard to the tft code suitable for fiat 500 prerestyling, there are many, one replaces the other.
You should tell me a code and I will tell you if it is suitable for your 500.

Return to “General”

Who is online

Users browsing this forum: No registered users and 9 guests