VAG KKL cable connections

multiecuscan program usage help
RogerAvenger
Posts: 4
Joined: 03 Mar 2014, 21:50

Re: VAG KKL cable connections

Post by RogerAvenger » 03 Mar 2014, 21:55

Gatter wrote:Hahaha Check this out! My new chineese VAGKKL cable..
Airbag is soldered to pin4-5, instead of pin3! :D
ESP is soldered to pin11-12, instead of pin12-13. :D
After the modification it works properly.. So first of all you should check the cable for correct pinout. 8-)

VAG-409-KKL-USB-FIAT-ECU-scan.jpg
Cable1.jpg
Cable2.jpg
Hi Gatter, I bought the same cable and I'm not able to connect to the airbag ecu, could you or anyone with the knowledge please indicate what's wrong with it and how to fix it?

EDIT: Is this the solution?
Image

Alfaeddy
Posts: 1350
Joined: 19 Feb 2011, 17:43
Location: Germany , Aarbergen

Re: VAG KKL cable connections

Post by Alfaeddy » 04 Mar 2014, 06:01

Hello

Also, no way, you must not connect the terminals.
The pin 3 must go to the board input to which also the pin 7.

But beware! then the pin 7 must have unable to connect to the board

The easiest way to solve a switch

Greetings Eddy

RogerAvenger
Posts: 4
Joined: 03 Mar 2014, 21:50

Re: VAG KKL cable connections

Post by RogerAvenger » 04 Mar 2014, 12:51

Alfaeddy wrote:Hello

Also, no way, you must not connect the terminals.
The pin 3 must go to the board input to which also the pin 7.

But beware! then the pin 7 must have unable to connect to the board

The easiest way to solve a switch

Greetings Eddy
I'm not sure I get what you're saying, I'm sorry. I can connect to the engine ecu and the abs without problems, It's the airbag that doesn't work, and from Gatter comments I take that they are soldered wrong, I need to know which cables to change please.

Alfaeddy
Posts: 1350
Joined: 19 Feb 2011, 17:43
Location: Germany , Aarbergen

Re: VAG KKL cable connections

Post by Alfaeddy » 04 Mar 2014, 19:34

Hello

I told you once drawn up a plan as should be the connection.
With a switch, the link should be established.

Because you should not extraneous signals such as Read the Motorecu or ABS
allowed to come to the airbag control unit.

There are also people to easily connect from pin 3 to pin 1 + Pin7 solder.
But there is no guarantee

To work on the airbag should only be done with much caution.

Greetings Eddy
8x9ACmD  markiert.jpg
8x9ACmD markiert.jpg (102.32 KiB) Viewed 9646 times

RogerAvenger
Posts: 4
Joined: 03 Mar 2014, 21:50

Re: VAG KKL cable connections

Post by RogerAvenger » 05 Mar 2014, 15:18

Alfaeddy wrote:Hello

I told you once drawn up a plan as should be the connection.
With a switch, the link should be established.

Because you should not extraneous signals such as Read the Motorecu or ABS
allowed to come to the airbag control unit.

There are also people to easily connect from pin 3 to pin 1 + Pin7 solder.
But there is no guarantee

To work on the airbag should only be done with much caution.

Greetings Eddy
8x9ACmD markiert.jpg
Look, I really appreciate you trying to help me, but I don't understand anything of what you've said or drawn, try maybe google translator if you still have the good will ^^

Gatter
Posts: 17
Joined: 18 Dec 2013, 13:58
Location: Hungary, Balaton

Re: VAG KKL cable connections

Post by Gatter » 05 Mar 2014, 16:44

Hi RogerAvenger!

Don't need any other switch!! Your picture is correct! You only need to remove the black cable from pin4-5 and then solder it to pin3 (airbag)! The switch must be in "3" (airbag) position!! After this mod, you can read the airbag module! 8-)

RogerAvenger
Posts: 4
Joined: 03 Mar 2014, 21:50

Re: VAG KKL cable connections

Post by RogerAvenger » 05 Mar 2014, 17:31

Gatter wrote:Hi RogerAvenger!

Don't need any other switch!! Your picture is correct! You only need to remove the black cable from pin4-5 and then solder it to pin3 (airbag)! The switch must be in "3" (airbag) position!! After this mod, you can read the airbag module! 8-)
Thank you very much, these chinese sellers.. eh hehe, thanks eddy too for trying!

Almanil
Posts: 3
Joined: 15 Apr 2014, 22:26

Re: VAG KKL cable connections

Post by Almanil » 15 Apr 2014, 22:40

Hi.
I also have a chinese VAG/KKL cable and I am not able to get it working. I have a little bit different version than you have discussed here before. Unfortunately I did not understood what repair has to be done. Till today I thought that the problem is in my laptop. I can connect to the chip but I am unable to connect to the car(Lancia Lybra). Now I think the mistake might be in pin setup. Can you please tell me if there is anything wrong with my setup and if so how I can repair it. If there is anything clear I will try to explain it.
Thank you very much for your help.
Attachments
IMG_3397.jpg
IMG_3397.jpg (160.04 KiB) Viewed 9475 times
IMG_3395.jpg
IMG_3395.jpg (143.79 KiB) Viewed 9475 times

Alfaeddy
Posts: 1350
Joined: 19 Feb 2011, 17:43
Location: Germany , Aarbergen

Re: VAG KKL cable connections

Post by Alfaeddy » 16 Apr 2014, 06:28

Hello

In the pictures of course no error can be seen.
Either your KKL defective or unfortunately very often the settings are not correct

If your KKL interface properly recognized in the Control Panel?
Otherwise, try it with this driver

http://www.ftdichip.com/Drivers/VCP.htm

Greetings Eddy

Almanil
Posts: 3
Joined: 15 Apr 2014, 22:26

Re: VAG KKL cable connections

Post by Almanil » 16 Apr 2014, 06:35

Hi.
In device managers I do not have any issues so I assume it is done ok. I will try this driver after I get home and see what will happen.
Thank you very much for your help.

Post Reply