FAULTY ELM 327 INTERFACES DE-MYSTIFIED (READ HERE)

multiecuscan program usage help
worldsat400
Posts: 1
Joined: 03 May 2018, 12:32

Re: FAULTY ELM 327 INTERFACES DE-MYSTIFIED (READ HERE)

Post by worldsat400 » 05 May 2018, 10:33

Hi all,

This post is extremely interesting and I would like to thank all the people who shared solutions for different models of ELM327 interfaces. I went through all the pages and didn't find anything related to my specific device (Bluetooth ELM 327). The closest circuit board I found was posted by lonerunner at the bottom of page 211. Alfaeddy answered that
His interface test shows that this ELM may not be compatible with Multiecuscan. It is often the case when the version v1.5 in ATZ and ATI is displayed the interface as not with MES functional. But There are also v1.5 interface which work problem-free.
I wonder if anything has changed since 7 months?
I did'nt find any ~120 Ohm resistor on my board. My car (Renault Megane 4) is not supported by MES, but this is the only forum post I found on the web dealing with fixing ELM327 clones. My device is working perfectly fine with software like Torque, but I would like to acces CAN bus from DDT4ALL or Pyren and it doesn't work.
Like other people on this post I tested with MES, and if I set the interface Type to ELM 327 Bluetooth, the test fails, but if I set the type to OBDKey 1.40 Bluetooth it successes. Please find below both tests results and also a test done with Pyren which shows 10 commands out of 95 tested that fail.
From what I read so far, I am pretty sure that I will have to buy another interface, but I thought it was worth asking on this post before doing so. And also it is not so easy to find in the large offer on the web a low cost interface that will work for sure.

Kind regards,

ImageImage

Code: Select all

MES test interface type ELM327
COMMAND: ATZ
RESPONSE: ATZ
ü
ELM327 v1.5
>
COMMAND: ATI
RESPONSE: ATI
ELM327 v1.5
>
COMMAND: ATE0
RESPONSE: ATE0
?
>
COMMAND: ATL0
RESPONSE: ATL0
?
>
COMMAND: ATH0
RESPONSE: ATH0
?
>
COMMAND: ATSPC
RESPONSE: ATSPC
?
>
COMMAND: ATS0
RESPONSE: ATS0
?
>
COMMAND: ATCAF0
RESPONSE: ATCAF0
?
>
COMMAND: ATCFC0
RESPONSE: ATCFC0
?
>
COMMAND: ATCRA 7B0
RESPONSE: ATCRA 7B0
?
>
COMMAND: ATSH 7B0
RESPONSE: ATSH 7B0
?
>
COMMAND: ATAT1
RESPONSE: ATAT1
OK
>
COMMAND: ATST41
RESPONSE: ATST41
?
>
COMMAND: ATBI
RESPONSE: ATBI
?
>
WARNING: This interface is not compatible with ELM 327 1.3! Will not connect to any CAN module.

Code: Select all

MES test interface type OBDKey
Testing OBDKey...
COMMAND: ATZ
RESPONSE: ATZ
ü
ELM327 v1.5
>
COMMAND: ATI
RESPONSE: ATI
ELM327 v1.5
>
COMMAND: ATE0
RESPONSE: ATE0
OK
>
COMMAND: ATL0
RESPONSE: OK
>
COMMAND: ATH0
RESPONSE: OK
>
COMMAND: ATSPC
RESPONSE: OK
>
COMMAND: ATS0
RESPONSE: OK
>
COMMAND: ATCAF0
RESPONSE: OK
>
COMMAND: ATCFC0
RESPONSE: OK
>
COMMAND: ATCRA 7B0
RESPONSE: OK
>
COMMAND: ATSH 7B0
RESPONSE: OK
>
COMMAND: ATAT1
RESPONSE: OK
>
COMMAND: ATST41
RESPONSE: OK
>
COMMAND: ATBI
RESPONSE: OK
>
This interface is compatible with ELM 327 1.4! Should connect properly with all CAN modules.

Code: Select all

Pyren test
Opening ELM
v1.0   ATZ  [OK]
v1.0   ATE1  [OK]
v1.0   ATL0  [OK]
v1.0   ATI  [OK]
v1.0   AT@1  [OK]
v1.0   ATAL  [OK]
v1.0   ATBD  [OK]
v1.0   ATBI  [OK]
v1.0   ATCAF0  [OK]
v1.0   ATCFC1  [OK]
v1.0   ATCP 01  [OK]
v1.0   ATCS  [OK]
v1.0   ATCV 1250  [OK]
v1.0   ATD  [OK]
v1.0   ATDP  [OK]
v1.0   ATDPN  [OK]
v1.0   ATH0  [OK]
v1.0   ATI  [OK]
v1.0   ATIB 10  [OK]
v1.0   ATIB 96  [OK]
v1.0   ATL1  [OK]
v1.0   ATM0  [OK]
v1.0   ATMA  [OK]
v1.0   ATMR 01  [FAIL]
v1.0   ATMT 01  [OK]
v1.0   ATNL  [FAIL]
v1.0   ATPC  [OK]
v1.0   ATR1  [OK]
v1.0   ATRV  [OK]
v1.0   ATSH 001122  [OK]
v1.0   ATSH 012  [OK]
v1.0   ATSP A6  [OK]
v1.0   ATSP 6  [OK]
v1.0   ATCM 123  [OK]
v1.0   ATCM 12345678  [OK]
v1.0   ATCF 123  [OK]
v1.0   ATCF 12345678  [OK]
v1.0   ATST FF  [OK]
v1.0   ATSW 96  [OK]
v1.0   ATSW 34  [OK]
v1.0   ATTP A6  [OK]
v1.0   ATTP 6  [OK]
v1.0   ATWM 817AF13E  [OK]
v1.0   ATWS  [OK]
v1.1   ATFC SD 300000  [OK]
v1.1   ATFC SH 012  [OK]
v1.1   ATFC SH 00112233  [OK]
v1.1   ATFC SM 1  [OK]
v1.1   ATPP FF OFF  [OK]
v1.1   ATPP FF ON  [OK]
v1.1   ATPPS  [OK]
v1.2   ATAR  [OK]
v1.2   ATAT1  [OK]
v1.2   ATDM1  [FAIL]
v1.2   ATIFR H  [OK]
v1.2   ATIFR0  [OK]
v1.2   ATIIA 01  [OK]
v1.2   ATKW0  [OK]
v1.2   ATMP 0123 [FAIL]
v1.2   ATMP 0123 4  [FAIL]
v1.2   ATMP 012345  [FAIL]
v1.2   ATMP 012345 6  [FAIL]
v1.2   ATSR 01  [OK]
v1.3   ATCRA 012  [OK]
v1.3   ATCRA 01234567  [OK]
v1.3   ATD0  [OK]
v1.3   ATFE  [OK]
v1.3   ATJE  [OK]
v1.3   ATJS  [OK]
v1.3   ATKW  [OK]
v1.3   ATRA 01  [OK]
v1.3   ATS1  [FAIL]
v1.3   ATSP 00  [OK]
v1.3   ATV0  [OK]
v1.4   ATCEA  [OK]
v1.4   ATCEA 01  [OK]
v1.4   ATCV 0000  [OK]
v1.4   ATIB 48  [OK]
v1.4   ATIGN  [OK]
v1.4   ATPB 01 23  [OK]
v1.4   ATRD  [OK]
v1.4   ATSD 01  [OK]
v1.4   ATSI  [FAIL]
v1.4   ATFI  [FAIL]
v1.4   ATSS  [OK]
v1.4   ATTA 12  [OK]
v1.4   ATCSM1  [OK]
v1.4   ATJHF1  [OK]
v1.4   ATJTM1  [OK]
v1.4   ATJTM5  [OK]
v1.4b  ATCRA  [OK]
v2.0   ATAMC  [OK]
v2.0   ATAMT 20  [OK]
v2.1   ATCTM1  [OK]
v2.1   ATCTM5  [OK]
****************************************
Uncompatible adapter on ARM core
 pyren would not work with it

Result: 85 from 95
 Max version:v2.1
Last edited by worldsat400 on 06 May 2018, 17:09, edited 1 time in total.

vcfan
Posts: 1
Joined: 05 May 2018, 23:47

Re: FAULTY ELM 327 INTERFACES DE-MYSTIFIED (READ HERE)

Post by vcfan » 06 May 2018, 00:06

rtfw61v2 wrote:Hi guys, i have just bought this elm327 clone from aliexpress, obviously cannot works with my Alfa Romeo 147 1.6 TS 16v. There are some inscriptions on the card "A-L07AJ_M", "M160421" and "M160413". I read that it was enough to remove some resistance to make it work properly. Can someone help me?
I found solution for people with this board. looks like defective pcb design so stm32 chip is always stuck in programming mode. just short these 2 pads (solder thin wire) and it will work.
Image

Ackhe
Posts: 1
Joined: 12 May 2018, 07:28

Re: FAULTY ELM 327 INTERFACES DE-MYSTIFIED (READ HERE)

Post by Ackhe » 12 May 2018, 07:50

Hello guys. Can anyone help me with this interface? Fiat F-super interface. I search through the topic and i didn't find this model. I am trying to connect to ECU on a Alfa Romeo 156 1.9 Jtd 2003 , and i can't. I was successfully in connecting to ECU with the interface software but it's very limited (i can read only errors) and i would like to connect with multiecuscan. I know it is a piece of.....but i'm thinking that maybe someone has a fix for this. If anyone can help me i would appreciate it. Thanks.
Later edit: I am trying to upload pictures with the interface and it seems that i'm getting the message "sorry the board attachment quota has been reached"
Instead I've uploaded them here. Asking admins maybe they can help. Thanks :)

https://drive.google.com/open?id=1oThDk ... FjzH9FoGWl

https://drive.google.com/open?id=1j6TtR ... 6kfJflpclP

https://drive.google.com/open?id=1t9ZUc ... Z7mRCpZi9t

Yaheii
Posts: 1
Joined: 15 May 2018, 19:15
Location: France

Re: FAULTY ELM 327 INTERFACES DE-MYSTIFIED (READ HERE)

Post by Yaheii » 16 May 2018, 10:26

Hi, is anyone ever seen this model of Bluetooth ELM ? And how can I connect to CAN with it ?

https://www.noelshack.com/2018-20-3-152 ... 213802.jpg

Thx :)

pio
Posts: 1
Joined: 19 May 2018, 19:12

Re: FAULTY ELM 327 INTERFACES DE-MYSTIFIED (READ HERE)

Post by pio » 19 May 2018, 19:28

Hello everyone! I'm new to the forum and I do not speak English, so I'm using GoogleTranslate to write to you, so do not be surprised if the translation is bad! :lol: Would you please tell me what is the resistance to remove at the elm327 wifi circuit that I purchased? Thanks in advance. :) :) :)
Pio

Image
Image
Image
Image

dani01
Posts: 1
Joined: 09 Jun 2018, 08:35

Re: FAULTY ELM 327 INTERFACES DE-MYSTIFIED (READ HERE)

Post by dani01 » 09 Jun 2018, 08:41

Hello,

i have a ELM327 mini (bluetooth)
can this work with the multiecuscan sofware?
Please see the attached photo.

cxem
Posts: 28
Joined: 24 Jan 2015, 09:10
Location: Russia, Syktyvkar

Re: FAULTY ELM 327 INTERFACES DE-MYSTIFIED (READ HERE)

Post by cxem » 18 Jun 2018, 05:17

program:ELM327Chat_Android
https://yadi.sk/d/hgeBI7L23Y3mGf
Command:ATPPS

DamianPL
Posts: 1
Joined: 03 Jul 2018, 20:25

Re: FAULTY ELM 327 INTERFACES DE-MYSTIFIED (READ HERE)

Post by DamianPL » 03 Jul 2018, 20:36

Hello,
I have Fiat Freemont 2.0 Multijet 2014, and I have two ELM cable.

First (RED) - doesnt detect ECU - work with BCM, ICP.
Second (green) - doesnt detect any module.

Attached photo in google pictures - link below.
Please anybody help. Because i dont know what im doing. Does buy new orignal ELM or do something with this?

https://photos.google.com/share/AF1QipN ... VEejZERXJB

dorcky
Posts: 1
Joined: 26 Jul 2018, 15:09

Re: FAULTY ELM 327 INTERFACES DE-MYSTIFIED (READ HERE)

Post by dorcky » 26 Jul 2018, 15:10

cxem wrote:New ELM327 PIC18 + 4MHz + no R 120om
https://ru.aliexpress.com/item/OBDII-EL ... 0.0.hddDk2
Do you test this interface, works OK? Thank`s!

multijetson
Posts: 1
Joined: 26 Jul 2018, 19:15

Re: FAULTY ELM 327 INTERFACES DE-MYSTIFIED (READ HERE)

Post by multijetson » 26 Jul 2018, 19:28

worldsat400 wrote:Hi all,

This post is extremely interesting and I would like to thank all the people who shared solutions for different models of ELM327 interfaces. I went through all the pages and didn't find anything related to my specific device (Bluetooth ELM 327). The closest circuit board I found was posted by lonerunner at the bottom of page 211. Alfaeddy answered that
His interface test shows that this ELM may not be compatible with Multiecuscan. It is often the case when the version v1.5 in ATZ and ATI is displayed the interface as not with MES functional. But There are also v1.5 interface which work problem-free.
I wonder if anything has changed since 7 months?
I did'nt find any ~120 Ohm resistor on my board. My car (Renault Megane 4) is not supported by MES, but this is the only forum post I found on the web dealing with fixing ELM327 clones. My device is working perfectly fine with software like Torque, but I would like to acces CAN bus from DDT4ALL or Pyren and it doesn't work.
Like other people on this post I tested with MES, and if I set the interface Type to ELM 327 Bluetooth, the test fails, but if I set the type to OBDKey 1.40 Bluetooth it successes. Please find below both tests results and also a test done with Pyren which shows 10 commands out of 95 tested that fail.
From what I read so far, I am pretty sure that I will have to buy another interface, but I thought it was worth asking on this post before doing so. And also it is not so easy to find in the large offer on the web a low cost interface that will work for sure.

Kind regards,

ImageImage
Hi all, my first post but not last...

I just bought my ELM327 interface and it is excactly same as above post from "worldsat400".

Same error code as beginning of whole threat. What we could do with that kind of PCB to get it work? Where is the resistor in that kind of PCB? Any help would be great or should I put the interface to the trash can :( This was a second try already...

Is there any link where I could buy really working interface for my Stilo 1.9 MultiJet II 8v?

Kindly Regards,
MultiJetSon

Post Reply