Grand Punto - fail to connect to engine, but body connects OK

Report any bugs found in multiecuscan
Post Reply
bucket
Posts: 3
Joined: 31 Oct 2022, 04:22

Grand Punto - fail to connect to engine, but body connects OK

Post by bucket » 31 Oct 2022, 04:38

Hi I have a 2007 Grand Punto and am able to sucessfully connect using a ELM 327 cable set. I have previously used this cable set from idiagnostics (https://idiagnostics.co.uk/) on another Grand Punto of the same age using the same laptop and sucessfully connected to both engine and gearbox.
With this Punto I can use my yellow cable to connect interact with the body control functions. I can do things like lock the doors. Using the green cable I am unable to connect to either the engine or the gearbox.
I have run the test and it reports taht I should be able to connect. I have checked all teh fuses on the car and checked that I get 12v at the OBD port. Everything seems OK, but I cant connect.
Any ideas?

shpuncik
Posts: 306
Joined: 19 Oct 2018, 16:43

Re: Grand Punto - fail to connect to engine, but body connects OK

Post by shpuncik » 31 Oct 2022, 12:09

https://www.multiecuscan.net/SupportedVehiclesList.aspx

where did you get idea that you need green cable to connect to engine?

bucket
Posts: 3
Joined: 31 Oct 2022, 04:22

Re: Grand Punto - fail to connect to engine, but body connects OK

Post by bucket » 02 Nov 2022, 05:54

I am pretty surew that I used the gren cable out of the set of three that I bought when I hav econnected to another Grand Punto. I have a green, yellw & red cable from the Idiagnostics kit and have tied them all. The yellow connects sucesfully to the body ecu

s130
Posts: 938
Joined: 20 Jan 2010, 10:07
Location: Wrexham, North Wales

Re: Grand Punto - fail to connect to engine, but body connects OK

Post by s130 » 02 Nov 2022, 16:23

Check Here: https://www.multiecuscan.net/SupportedVehiclesList.aspx

Most Puntos post Punto 03 are all CAN for ECU with NO adapter. Could be same for Gearbox
Fiat Strada/Ritmo Abarth 130TC, Barchetta 2005 , 500X Cross Plus

bucket
Posts: 3
Joined: 31 Oct 2022, 04:22

Re: Grand Punto - fail to connect to engine, but body connects OK

Post by bucket » 03 Nov 2022, 07:31

That worked! Seems obvious now. Thanks for that

Post Reply