Multiecuscan 4.8 REGISTERED Windows XP SP3 compatibility issue

Report any bugs found in multiecuscan
Post Reply
gr8ron
Posts: 2
Joined: 01 Feb 2022, 20:26

Multiecuscan 4.8 REGISTERED Windows XP SP3 compatibility issue

Post by gr8ron » 01 Feb 2022, 21:26

Hi,

I did a clean install of Windows XP SP3 on my old netbook (1,66 GHz CPU) only to use Multiecuscan. I ordered iDiagnostics OBD2 USB ELM 327 v1.4 adapter (SKU # 281712496622) from ebay ( https://www.ebay.com/sch/i.html?_nkw=281712496622 ) and installed the ELM USB drivers from https://www.idiagnostics.co.uk/drivers/elm.zip

After that I configured the interface settings (Interface Type: ELM 327 1.3/1.4/1.4b/2.1, Serial Port: COM 4 (USB Serial Port)) in Multiecuscan. Test button shows responses 2x "ELM327 v1.4", 12x "OK" and "This interface is compatible with ELM 327 1.4! Should connect properly with all CAN modules". All good so far.

However, when I click the "Scan" button the program crashes with a message about an unexpected error (with a suggestion to send an error report to Microsoft). The program apologises, and then closes after I click the "Don't send" button.

Also, I can't connect any of the engine ECU modules. The program shows "CONNECTION FAILED" and "Aborted by user" regardless of which ECU module I choose to try to connect to. I run Multiecuscan as administrator, my car make is "Fiat" and car model is "Grande Punto 1.4 8V".

I ran the "Repair" function of the Multiecuscan installer, but unfortunately that did not seem to fix the issue for me.

I contacted the seller of the ELM 327 adapter and they recommended registering Multiecuscan, which I did, but that didn't fix the issue either.

Is there anything that I can do to make Multiecuscan work on my netbook running Windows XP SP3? I have Microsoft .NET Framework 2.0 Service Pack 1 installed.

If I uninstall Multiecuscan and reinstall it on the same computer & OS, do I need a new license/activation key for the full version?

Kind regards

gr8ron
Posts: 2
Joined: 01 Feb 2022, 20:26

Re: Multiecuscan 4.8 REGISTERED Windows XP SP3 compatibility issue

Post by gr8ron » 05 Feb 2022, 05:35

I managed to solve this issue by installing Microsoft .NET Framework 3.5 Service Pack 1. Maybe the minimum system requirements should be updated accordingly? Currently it states "Microsoft .NET Framework Version 2.0 SP1", which isn't enough on my Windows XP SP3 netbook.

While searching for a fix I moved the license to a different computer. Now I need to wait a month to move the license back to my Windows XP SP3 computer, and then I only have 8 license transfers left. :)

Kind regards

Post Reply